A Non-Traditional Land Rover Club
 
HomeCalendarGalleryFAQSearchMemberlistUsergroupsRegisterLog in
Share | 
 

 Transmission neutral sensor

View previous topic View next topic Go down 
AuthorMessage
Hilltoppersx
Admin


Posts: 2842
Join date: 2010-09-28
Location: Westchester, NY

PostSubject: Transmission neutral sensor   Fri Aug 26, 2011 2:35 pm

fuck.. i got the main 3 bolts off the xyz. in rave it is referred to as a "Transmission neutral sensor" but I can't find where the heck the diagram is. i only found mention of it in the D2 workshop manual section but no drawings or breakdowns. im stuck trying to break the nut loose that holds the shift cable to the unit. every time i put pressure on it the shift cable starts to bend.. (not good).. i tried using vice gribs to get a hold on teh cable but it's not enough. it can't be that complicated. also the damn wiring harness ne near impossible to get apart so i want to see how that is held up to the frame so i can take it off the holder and get a better handle on it. if anyone can help me find it in RAVE or online it would be much appreciated. i tried xyz and everyother name... wtf
Back to top Go down
View user profile http://nelrc.iftopic.com
Hilltoppersx
Admin


Posts: 2842
Join date: 2010-09-28
Location: Westchester, NY

PostSubject: Re: Transmission neutral sensor   Sat Aug 27, 2011 4:55 am

found it in RAVE. it goes by three different names in RAVE... nice.

i got it off, drilled it open and it was trashed inside.





yes that is mud.

i cleaned it up real good, sealed it with rtv, put it back together and reattached the wiring harness and started the truck. nothing came up. so now like a moron, the key is stuck. it won't release the key because it doesn't know if it's in park. but it won't even turn to the off position so things like the clock and my cb are still getting power. so i had to disconnect the battery. i went to pull the hood latch and the plastic snapped! so i had to use pliers to grab the wire. then disconnect the battery... what a mess. also when trying to get that nut loose on the transmission cable i snapped it in half. so ill be buying one of those. still have to reroute the A/C drain that is literally right above the sensor. going to pick up an extra sensor and clean it and seal it because i'm not sure if this one is shot but i figured a rebuild is free so it's worth a shot... needless to say my truck is a lawn ornament right now.
Back to top Go down
View user profile http://nelrc.iftopic.com
Hilltoppersx
Admin


Posts: 2842
Join date: 2010-09-28
Location: Westchester, NY

PostSubject: Re: Transmission neutral sensor   Sat Aug 27, 2011 4:56 am

those are also the last photos from my cell phone because it is dead as well. damn thing won't turn on... so now it's 5 am and im on verizon shopping.
Back to top Go down
View user profile http://nelrc.iftopic.com
Long Haul
NELRC Original Gangsta


Posts: 686
Join date: 2010-10-07
Age: 35
Location: Lancaster Pa

PostSubject: Re: Transmission neutral sensor   Sat Aug 27, 2011 8:14 am

Sounds like your having a good day so far lol. I never messed with those switches so Im of no help. Good luck.
Back to top Go down
View user profile
 

Transmission neutral sensor

View previous topic View next topic Back to top 
Page 1 of 1

 Similar topics

-
» Transmission neutral sensor
» 5.3 LS Vortec Engine and 4L60E Transmission
» Transmission lines
» Gender-neutral writing
» crankshaft sensor

Permissions in this forum:You cannot reply to topics in this forum
 :: Truck Talk-