A Non-Traditional Land Rover Club
 
HomeCalendarGalleryFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 high idle delema

View previous topic View next topic Go down 
AuthorMessage
TOM R
NELRC Pack Leader
NELRC Pack Leader
avatar

Posts : 543
Join date : 2013-05-19
Location : south N.J. / ne VA.

PostSubject: high idle delema   Tue Jul 02, 2013 3:54 pm

ok so I have a high idle condition, checked linkages, vacuum leaks, swapped the tps and iac

after reading a ton of threads from google search seems the only fix is to goto a dealer and pay to have the base idle reset in the ecu

are there and shops in south jersey with this capability or do I have to goto rover in cherry hill?
Back to top Go down
View user profile
Therealassmikeg
Mud Tire Addict


Posts : 56
Join date : 2012-02-22

PostSubject: Re: high idle delema   Wed Jul 03, 2013 6:43 am

yes you need to reset the adaptions (closed throttle)
if you have an off brand battery or one of those red/yellow tops
replace it with an interstate or die hard or you'll be resetting it again
Chris from 5 corners in Long Branch may or may not be able to reset it
I'm not sure what capabilities his scanner has,
https://www.facebook.com/5CornersAutoRepair

Back to top Go down
View user profile
TOM R
NELRC Pack Leader
NELRC Pack Leader
avatar

Posts : 543
Join date : 2013-05-19
Location : south N.J. / ne VA.

PostSubject: Re: high idle delema   Wed Jul 03, 2013 11:02 am

just blew 177 at dealer they could not reset idle and said they could not get my spare remote to program

my ultra gauge only displays the 1447 code but the said it has

1447,0446,0451,0443,1508,0122

said they could diagnose for another 112 per hour affraid 

I am guessing something got wet and will not dry since it rains every day

whats the deal with the battery? had this batt since I owned it like 4 years seems fine
Back to top Go down
View user profile
Hilltoppersx
Admin
avatar

Posts : 3182
Join date : 2010-09-28
Location : Westchester, NY

PostSubject: Re: high idle delema   Wed Jul 03, 2013 4:32 pm

get yourself one of those cheap or free testers from HF so you can check the voltage on the battery. isnt 1447 the purge valve? fuck i hate that code....gas cap, purge valve, rusted out fuel neck?
Back to top Go down
View user profile http://nelrc.iftopic.com
TOM R
NELRC Pack Leader
NELRC Pack Leader
avatar

Posts : 543
Join date : 2013-05-19
Location : south N.J. / ne VA.

PostSubject: Re: high idle delema   Wed Jul 03, 2013 5:38 pm

I have the ultra gauge hooked in it is a code reader and can clear do not know why these are not displaying just the 1447 and it is purge changed it still there but I do have pressure when I take off the gas cap some times guess I need a gas cap

they gave me a printout of the codes and what they are for there are like 3 that are for purge/gas tank pressure

then tps low voltage and iac open guessing these codes were set when I had the plugs off key on claimed they would not clear

I can look at the ultra gauge and see streaming data the tps is working correct, the maf, intake temp, coolant temp, O2 all appear fine, I plugged in the iac off the motor and had dad turn on the key it did the self check in out and is clean along with the throttle body and iac needle seat

what am I checking batt voltage for? I am running at 13.7 volts +/- and no problems cranking

not trying to be a smart A@# just want it fixed

if it persists when I return home next week I will pull the cover for gas sendor and unplug ael read somewhere that worked for a guy see if it is part of the prob and check the vss since that according to rave can affect rpm speedo does work it is 5 fast though

if I make it to a u pull and get a ecm I read I also need the alarm ecu? if so where is it located?
Back to top Go down
View user profile
Therealassmikeg
Mud Tire Addict


Posts : 56
Join date : 2012-02-22

PostSubject: Re: high idle delema   Thu Jul 04, 2013 7:16 am

Tom, I'm not really sure why the battery causes this to happen, it just does.
It either spikes a higher, or low voltage when cranking the ecu then mistakenly reads
the learned closed throttle value to a higher or lower value. this in turn locks the stepper
motor to a fixed open value and the idle then races or will not compensate when the a/c is
on. a battery that is 4 years old should be replaced.
If you get the adaptions reset it just gonna happen again.
Unfortunately the dealer you went to probably doesn't have many/or any techs that know this.
nor do they really want to work on this old shit.
Doesn't mean they're not good techs, but just that they may only know the newer stuff.
You can just swap the ecm, BUT you then need to relearn the security immobilization AND closed throttle, which you'll need the t4 or a capable scanner.
fuel tank pressure fault could be just a plugged vent hose for the tank pressure sensor.


Back to top Go down
View user profile
TOM R
NELRC Pack Leader
NELRC Pack Leader
avatar

Posts : 543
Join date : 2013-05-19
Location : south N.J. / ne VA.

PostSubject: Re: high idle delema   Wed Jul 10, 2013 2:33 pm

I now have eandering idle and tps 5.24/12.2. Ideas?
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: high idle delema   

Back to top Go down
 
high idle delema
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Ouran High School Host Club!
» Blind high elf
» high voltage on speaker terminals of Mk4?...
» what is (or was) your least favorite part of high school?
» Calvin Klein Collection Presents The First Party On The High Line

Permissions in this forum:You cannot reply to topics in this forum
 :: Tech Help-
Jump to: